Author Topic: Fun with my Brumby  (Read 3738 times)

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Fun with my Brumby
« on: January 26, 2012, 07:36:29 PM »
This is my 1800cc 1984 Subaru Brumby
It cost me $640 to buy and about $50 to get running
Absolutely excelent offroader vehicle
also has had 2inch lift kit fitted
and a homemade snorkel which consists of vacume hoses and ellectrical tape :P
« Last Edit: January 26, 2012, 10:28:06 PM by jordwaine »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #1 on: January 26, 2012, 08:01:39 PM »
« Last Edit: January 26, 2012, 08:08:17 PM by jordwaine »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #2 on: January 26, 2012, 08:03:17 PM »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #3 on: January 26, 2012, 08:03:55 PM »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #4 on: January 26, 2012, 08:04:30 PM »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #5 on: January 26, 2012, 08:05:53 PM »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #6 on: January 26, 2012, 08:06:24 PM »

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #7 on: January 26, 2012, 08:11:21 PM »

Offline Phizinza

  • Fizz-in-za
  • Administrator
  • Happy Camper
  • *****
  • Posts: 3358
  • Yip yip
    • View Profile
    • Offroading Subarus
Re: Fun with my Brumby
« Reply #8 on: January 26, 2012, 10:28:32 PM »
That is a bargain price, and for a T-top Brumby! If you want to jump it, might think about capping the strut top rubbers on the front, as they punch through after a while.

Offline jordwaine

  • Newbie Subie
  • *
  • Posts: 11
    • View Profile
Re: Fun with my Brumby
« Reply #9 on: February 21, 2012, 10:23:14 AM »
the beast isnt up and running atm because either the electric fuel pump is rooted :P and the struts are pinching through